Официальный Форум технической поддержки сервиса ForumBB

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.



"JavaScript должен быть включен."

Сообщений 1 страница 2 из 2

1

Если у вас постоянно вылезает ошибка:

JavaScript должен быть включен. Если ошибка повторяется - обратитесь, пожалуйста, на форум технической поддержки сервиса.

Попробуйте закрыть браузер и снова открыть и отправить сообщение. Если не ошибка повторяется - нажмите ctr+f5 на странице отправки сообщения. Так же на эту ошибку влияют скрипты, которые вставлены для авторизации пользователя. Удалите их, скоро напишут новые.

Есть ещё решение, это обязан сделать каждый Поставить java плагин или полную версию, она небольшая (версия бесплатная, так же есть русскоязычная), и всегда пригодится. (Ссылка на программу - JAVA SOFTWARE FOR WINDOWSИнструкция по установке, там даже есть и для других систем - совместим со всеми известными браузерами...)

Ещё надо скачать дополнительно и поставить обязательно:
Software:
1) MSJVM Diagnostic Tool.
2) Microsoft J# Browser Controls (JBC).
3) Java Language Conversion Assistant (JLCA).

Всё найдёте на оффициальной странице Microsoft =>ссылка

Все скрипты, связанные с авторизацией - на этом форуме их было много представлено, выбросте пока вообще. Они писались до того, как были сделаны изменения  в структуре страницы сообщений на форуме. Теперь же они вызывают конфликт. Избавьтесь от них, они будут переписаны.

Admin написал:
В системе идет привязка к сессии. Т.е. Вы можете отправить сообщение с открытой страницы в течение того времени, что указано в:
Администрирование - Время и тайм-ауты - Тайм-аут визита (внимание! время нужно указывать в секундах!).
По-умолчанию был самый оптимальный вариант для Тайм-аут визита: 600 секунд.
И для Тайм-аут online: 300 секунд.
Настоятельно(!) рекомендуется выставить такие значения.
У Вас у всех стоит дополнительный скрипт быстрой авторизации.
Замените все process_form на любое другое название, к примеру на mynew_form и все заработает.
Заметьте, что дополнительные скрипты должны подстраиваться под форум, а не наоборот.
Проверьте, чтобы в настройках браузера был включен javascript. Закройте браузер. Откройте снова. Думаю, может закешировало (желательно почистить кеш). Если все равно после этого не отправляется - отпишите, буду искать причину.
Вы не должны дублировать существующую функцию function process_form.
А должны назвать свою функцию своим уникальным именем.

0

2

Чтобы включить поддержку JavaScript, Вам нужно:

Если Вы пользуетесь браузером Internet Explorer:

Зайти в меню "Сервис" ("Tools") -> "Свойства обозревателя" ("Internet Options")
Выбрать закладку "Безопасность" ("Security")
Нажать кнопку "Другой..."("Custom Level...")
В появившемся списке найти раздел "Сценарии" ("Scripting")
В подразделе "Активные сценарии" ("Active Scripting")
установить переключатель в положение "Разрешить" ("Enable")
Нажать кнопку "ОК"

Если Вы пользуетесь браузером Firefox:

Зайти в меню "Инструменты" ("Tools") -> "Настройки..." ("Options...")
Выбрать раздел "Web-Функции" ("Web Feauters")
Поставить флажок напротив пункта "Использовать JavaScript" ("Enable JavaScript")
Нажать кнопку "ОК"

Чтобы проверить версию Вашего браузера, зайдите в меню "Справка" ("Help") -> "О программе" ("About").

0