Официальный Форум технической поддержки ForumBB

Объявление


С 15.02.2017 прекращается техническая поддержка по ICQ, она будет осуществлятся только на данном форуме и по электронной почте help@forumbb.ru.

Для удобного поиска работает - «Поиск по форуму».
При возникшей проблеме Обязательно указывайте адрес форума!


Вопросы по рекламе на ForumBB: E-mail: sales@forumbb.ru, ICQ: 1-130-134, skype: alex_derenchuk.
По всем остальным вопросам, пишите: E-mail: admin@forumbb.ru, ICQ: 1-130-134.

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.



Фотографии

Сообщений 1 страница 20 из 29

1

Добрый день. Подскажите, пожалуйста, как можно сделать так, чтобы фотографии размещенные на форуме могли видеть только зарегистрированные на нем посетители, а гости, соответственно, нет?
Не смогла здесь найти, где можно об этом почитать.

И еще один вопрос. Фотографии на форум можно загрузить при помощи сервисы хранения, а еще можно через форум. Но эта функция некоторым пользователям почему-то не доступна (в том числе и мне), а у некоторых пользователей она работает. Нажимаю на "прикрепить изображение", открывается несколько строк, нажимаю на "обзор", ссылка с компьютера там появляется, нажимаю "готово", но в окошке ответа ничего нет. В чем причина?

Отредактировано Бараш (19.08.2011 16:00:26)

0

2

Администратирование ----->>> Форумы ----->>> выбирайте форум в котором эта тема и убираем галочку "Чтение форума", группе "Гости" -

http://xmages.net/storage/10/1/0/5/4/upload/7c3bbc4b.png

0

3

Fin
Спасибо. Поняла. Но это не совсем то. Мне хотелось бы, чтобы гость мог читать форум, а вот фотографии в сообщениях не видел, только после регистрации на форуме. Или такое не возможно?

0

4

Бараш
Поищу скрипт.

0

5

Бараш
Вспомнил. С помощью скриптов никак только картинки не получится. Только если поставить картинки в "Скрытый текст". Ограничиться 1 сообщение можно.

Скрытый текст:

Для просмотра скрытого текста - войдите или зарегистрируйтесь.

Гости этого текста не видят.

0

6

Fin написал(а):

Вспомнил. С помощью скриптов никак только картинки не получится. Только если поставить картинки в "Скрытый текст". Ограничиться 1 сообщение можно.

Спасибо. Попробую. Хотя бы так уже хорошо. Очень надо, уж больно гости у нас "доброжелательные".

Отредактировано Бараш (20.08.2011 00:15:02)

0

7

Бараш
Больше никак. Либо скрытие от гостей подфорума, либо запрет перехода по все ссылкам, либо вообще запретить гостям просматривать темы.

0

8

Fin
Получилось! Огромное спасибо. Только теперь ошибка возникает почему-то. Картинка вставляется вот так:

Скрытый текст:

Для просмотра скрытого текста - войдите или зарегистрируйтесь.

и не работает. Почему она не правильно вставляется? Нажимаю на скрытый "текст" и вставляю ссылку на изображение. Ссылка вставляется вся, а вот вторая скобка [hide= уезжает при этом в конец при просмотре. Как исправить? Видно где-то ошибка есть, поэтому одни пользователи могут изображение через форум вставлять, а другие нет. И через "скрытый текст" тоже с ошибкой получается. Если скобку поставить на место, все работает, но так надо делать будет каждый раз.

Отредактировано Бараш (20.08.2011 00:34:03)

0

9

Бараш
Вот так(внизу код как я делал):

Скрытый текст:

Для просмотра скрытого текста - войдите или зарегистрируйтесь.


Код:
[hide=1][img]http://shot.photo.qip.ru/300886v.jpg[/img][/hide]

Отредактировано Fin (20.08.2011 00:34:06)

0

10

Fin
А я его так и ввожу, а он сам пишется вот так при просмотре:

Код:
[hide=[img]http://shot.photo.qip.ru/300886v.jpg[/img]][/hide]

Приходится вручную вторую скобку ставить на место. Он же должен автоматически сам правильно вставляться. Что не так я делаю?

Отредактировано Бараш (20.08.2011 00:40:40)

0

11

Бараш
Вы вводите в первое окошко когда появляется? Там вводите минимальное кол-во сообщений. которое должен иметь пользователь. После уже когда все готово вводите ссылку на картинку и получается вот так -

Код:
[hide=1][img]http://shot.photo.qip.ru/300886v.jpg[/img][/hide]

0

12

Бараш
Если не понятно покажу на скринах.

0

13

Fin написал(а):

Вы вводите в первое окошко когда появляется? Там вводите минимальное кол-во сообщений. которое должен иметь пользователь.

Это как? Я новичок, пока еще туплю. Я просто в ответе на форуме ввожу. Или что-то другое имеется в виду?

0

14

Fin написал(а):

Если не понятно покажу на скринах.

Ага!  :yep:  :blush:

0

15

Бараш написал(а):

Я новичок, пока еще туплю.

Я тоже когда-то такой был.

Бараш написал(а):

Ага!

Ищем в верхнем меню формы ответа "замок":
http://xmages.net/storage/10/1/0/1/0/upload/db878056.png
Щелкаем, и вводим в появившемся окне цифру - 1:
http://xmages.net/storage/10/1/0/d/1/upload/744c0419.png
Далее кликаем ОК:
http://xmages.net/storage/10/1/0/6/d/upload/061599bd.png
После вставляем в середину этого кода ссылку на картинку (обязательно с тегом

Код:
[img][/img]

):
http://xmages.net/storage/10/1/0/f/5/upload/8c4dd54c.png
И все!

Отредактировано Fin (20.08.2011 01:04:38)

0

16

Бараш написал(а):

И еще один вопрос. Фотографии на форум можно загрузить при помощи сервисы хранения, а еще можно через форум. Но эта функция некоторым пользователям почему-то не доступна (в том числе и мне), а у некоторых пользователей она работает. Нажимаю на "прикрепить изображение", открывается несколько строк, нажимаю на "обзор", ссылка с компьютера там появляется, нажимаю "готово", но в окошке ответа ничего нет. В чем причина?

Это так и должно быть. Вводите туда к примеру "..." и отправляйте, обязательно там появятся изображения выложенные вами.

0

17

Fin
СПАСИБО!!! Поняла! Все получилось!  :cool:
Доцент тупой!  :D

А со вторым вопросом можно подсказать? Здесь у меня получается так загружать фотографию (через "прикрепить изображение"), а на форуме нет, и у некоторых пользователей тоже самое, а один точно может и удивляется почему у меня не получается. Даже по телефону общались, все делала по его инструкции (хотя чего там делать), а фото так не вставляется, только через сервиры хранения. Может тоже чего не так делаю?

0

18

Бараш написал(а):

А со вторым вопросом можно подсказать? Здесь у меня получается так загружать фотографию (через "прикрепить изображение"), а на форуме нет, и у некоторых пользователей тоже самое, а один точно может и удивляется почему у меня не получается. Даже по телефону общались, все делала по его инструкции (хотя чего там делать), а фото так не вставляется, только через сервиры хранения. Может тоже чего не так делаю?

Fin написал(а):

Это так и должно быть. Вводите туда к примеру "..." и отправляйте, обязательно там появятся изображения выложенные вами.

0

19

Fin написал(а):

Вводите туда к примеру "..." и отправляйте, обязательно там появятся изображения выложенные вами.

:no:  не работает. Ссылка вставляется, изображения нет в ответе. А здесь получилось.

Отредактировано Бараш (20.08.2011 01:15:11)

0

20

Бараш
Отправляйте сообщение! В форме ответа это и не должно быть.

0