Официальный Форум технической поддержки сервиса ForumBB

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.



Проблема с HTML верх

Сообщений 1 страница 5 из 5

1

Здравствуйте!
Знающие люди, помогите мне, пожалуйста с одной проблемой.
Решив немного поэкспериментировать с дизайном форума, вставляю в HTML верх следующий код:

<style type="text/css">

HTML, BODY {background-color: #000000; background-image: url("http://rm.foto.radikal.ru/0709/c8/c4bb8da49415.gif"); background-repeat: repeatxy; background-attachment: fixed; background-position: top center;
}

#pun-title table {background-color: black;
height : 132px;
}

#pun-navlinks .container {
background-image: url("http://rz.foto.radikal.ru/0710/ed/3725cbfaa9bc.gif"); background-repeat: repeat;
}

#pun-navlinks a:hover {
color: red;
}

#pun-ulinks a:hover {
color: red;
}

#pun-ulinks .container {
background-color: #000000 !important;
}

#pun-announcement h2 {background-color: #000000;
}

#pun-announcement .container {background-color: #000000;
}

#pun-status .container { color: #CC9933;
background-color: #000000;
}

#pun-crumbs2 .container {
color : #CC9933; background-color : #000000 !important;

#pun-main h2 {
color : black;
background-color : transparent; background-image : url(http://rz.foto.radikal.ru/0710/ed/3725cbfaa9bc.gif);
}
#pun th {
color: red; background-color : #FF00FF; background-image : url(http://ru.foto.radikal.ru/0710/52/e9e23f789dd3.gif);
}

Div.icon {
background-image : url(http://ra.foto.radikal.ru/0710/5f/8c6a975d2ad9.gif);
background-repeat: no-repeat;
}

TR.inew Div.icon {
background-image : url(http://ru.foto.radikal.ru/0710/0f/e606a4dbb7b8.jpg);
background-repeat: no-repeat;
}

TR.isticky Div.icon {
background-image : url(http://rl.foto.radikal.ru/0710/19/63f6ed17b8ad.gif);
background-repeat: no-repeat;
}

#pun .tcl { color: # CC9933;
background-color: #000000; width: 20%;
}

#pun  .tc2 { color: # 000000;
background-image : url(http://rk.foto.radikal.ru/0710/cd/2c4b892f2a14.jpg);
background-repeat: repeat;
}

#pun .tc3 { color: # 000000;
background-image : url(http://rk.foto.radikal.ru/0710/cd/2c4b892f2a14.jpg);
background-repeat: repeat;
}

#pun .tcr { color: # CC9933;
background-color: #000000;
}

.modlist {display: none;}

#pun-main td {
border-color : # CC9933;
}

#pun-stats .container {
color : #CC9933;
background-color : #000000;
}

#pun-crumbs2 p.container {
color : #CC9933; background-color : #000000;
}

#pun-about p.container {
color : #CC9933; background-color : #000000;
}

#html-footer .container {background-color: #000000; color: # CC9933;}

#pun-main h1 {
color : black;
background-color : #FF00FF; background-image : url(http://rz.foto.radikal.ru/0710/ed/3725cbfaa9bc.gif);
}

#pun-main .pagelink {
color : black;
}

#pun-main .postlink {
color : black;
}

#pun-main .modmenu p.container {
color : #CC9933; background-color: #000000;
}

</style>

Но срабатывает он буквально для нескольких элементов, в то время как все остальные остаются прежними. Стиль Mybb Autumn, однако я уже перепробовала практически все и результат был тем же. Браузеры также использовала разные, думая, что проблема, выозможно, в них, но ничего не изменилось.
Очевидно, я что-то неправильно прописала в самом коде, но в одиночку разобраться с этим не могу. Если кого не затруднит, помогите мне, пожалуйста, ибо очень уж хочется поменять дизайн на что-нибудь новое, отличное от стандартного.

Адрес моего форума: http://marauders.forumbb.ru/

Отредактировано Lacrima_Mori (06.10.2007 01:44:48)

0

2

Lacrima_Mori написал(а):

Но срабатывает он буквально для нескольких элементов

Ты можешь впринципе менять тока цвета и рисунки на форуме! Все остальные элементы ты изменяешь при написании своего стиля! Читай FAQ по дизайну форума в CSS   Абсолютный помощник по дизайну CSS

+1

3

DREД написал(а):

Ты можешь впринципе менять тока цвета и рисунки на форуме!

Я разве меняю какие-либо другие параметры помимо цветов и рисунков для различных элементов?
Я читала FAQ, пользовалась помощником, ибо без них бы этот код составить не смогла. Устанавливала свой стиль, пробовала стандартные, но проблема в том, что форум как будто "не видит" моего кода, отображая только малую часть из вводимых мной настроек. Возможно, я что-то написала не так, однако свою ошибку найти не в состоянии... Не могли бы Вы мне с этим помочь?

Отредактировано Lacrima_Mori (20.10.2007 18:38:13)

0

4

Lacrima_Mori написал(а):

отображая только малую часть из вводимых мной настроек.

а ты код писала для верхнего скрипта и нижнего?

0

5

Все ксс коды ставятся вверх

0